「 SquirrelMail」のアーカイブを表示中です。

mineko のプロフィール写真

投稿者: mineko

Squirrelmail – Quick Save プラグイン

2009 年 8 月 10 日 (SquirrelMail)

Cookieを使って書きかけのメールを自動的に保存してくれる、とても役に立つプラグインです。

Plugins – Quick Save

Potのみの提供ですので日本語ファイルを作ります。

20090810

オプション→表示オプションで設定を変更できます。

mineko のプロフィール写真

投稿者: mineko

SquirrelMail Cookie Warning プラグイン

2009 年 8 月 10 日 (SquirrelMail)

SquirrelMail – Webmail for Nuts!.

ログインした際にCookieの受け付けを有効にしていないとエラーメッセージを表示するプラグインです。
JavaScriptでログイン前に知らせてた方が親切なような気がしますが、そんなところに手間をかける余裕がないのでこのプラグインを有効にしておきます。

でも日本語のランゲージファイルが有効にならず((+_+))、今のところ原文メッセージのまま放置しています。

mineko のプロフィール写真

投稿者: mineko

[SA36087] SquirrelMail Multiple Plugins Package Compromise

2009 年 8 月 10 日 (SquirrelMail)

squirrelmail ではよくあることですが、

セキュリティmemo からの転載です。

SquirrelMail の web サーバが 2009.07.16 に改ざんされたのだが、その際、 以下の 3 つのプラグイン

  • sasql-3.2.0
  • multilogin-2.4-1.2.9
  • change_pass-3.0-1.4.0

のパッケージが改ざんされたバージョンに入れかえられていたそうで。 改ざんされたプラグインを使用すると、パスワード情報などが外部に漏洩するそうだ。 正しいプラグインの MD5 は以下のとおりだそうで。

a492922e5b0d2245d4e9bc255a7c5755  sasql-3.2.0.tar.gz
b143f2dc82f9e98dd43c632855255075  multilogin-2.4-1.2.9.tar.gz
2cff7c5d4f6f5d8455683bb5d96bb9fe  change_pass-3.0-1.4.0.tar.gz

改ざんされるってことはそれだけニーズが高いということ?

未だにSquirrelMailを使わなきゃいけない現状も情けないといえば情けないです(>_<)。

mineko のプロフィール写真

投稿者: mineko

SquirrelmailのAdministratorプラグイン

2009 年 7 月 24 日 (SquirrelMail)

SSHなどでログインできるサーバーでは敢えて入れる必要のないプラグインです。

plugins/administrator または config にadmins というファイルを作ってAdministratorの権限にするユーザー名を1行毎登録しておきます(plugins/administrator/adminsがあるときconfig/adminsは無視されます)。

管理者でログインすると、オプションメニューに「管理」が追加されます。

今後も使うことはないと思いますので記念にスナップショットだけ取っておくことにします。

残りのエントリーを読む →

mineko のプロフィール写真

投稿者: mineko

SquirrelMail インストール

2009 年 7 月 23 日 (SquirrelMail, インストール)

なんだかんだ言ってもSquirrelMailほど馴染んでいる
Webメールアプリが無いもので、1.4.19をインストール

1.4.18から変更されているのは以下のファイル

二つのバージョンで異なっているのは以下のファイル
class/deliver/Deliver_SMTP.class.php
doc/ChangeLog
doc/ReleaseNotes
doc/presets.txt
doc/release_notes_archive/1.4/Notes-1.4.12.txt
doc/release_notes_archive/1.4/Notes-1.4.13.txt
doc/release_notes_archive/1.4Notes-1.4.18.txt
functions/global.php
functions/imap_general.php
functions/strings.php
plugins/filters/filters.php
plugins/filters/options.php
plugins/squirrelspell/js/crypto_settings.js
plugins/squirrelspell/js/decrypt_error.js

po/squirrelmail.pot
src/compose.php
src/options.php
src/redirect.php

言語ファイルは1.4.18のものがそのまま使えそうです。

開発環境のこともあるのでコードをUTF-8に書き直しています。